summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2004-04-08 11:10:24 +0000
committerBastien Nocera <hadess@src.gnome.org>2004-04-08 11:10:24 +0000
commit04544f0e2ff3b6800e847a018d09eb8cc8459645 (patch)
tree944afa8b682b2edaa5a14e9e197fe3a7f35356b8 /configure.in
parentc8f5ef0abf9e1fc2fdfe5b4520bf1ca42878f9b3 (diff)
downloadtotem-04544f0e2ff3b6800e847a018d09eb8cc8459645.tar.gz
updated removed TODO item detect newer xine-lib versions, and require them
2004-04-08 Bastien Nocera <hadess@hadess.net> * NEWS: updated * README: removed TODO item * configure.in: detect newer xine-lib versions, and require them Update the version to 0.99.10 * src/bacon-video-widget-xine.c: (bacon_video_widget_tick_send): * src/totem.c: (play_pause_set_label), (totem_action_eject), (update_mrl_label), (totem_action_set_mrl), (update_current_time): Make sure that the statusbar label and time show that the playback was completely stopped, don't show a "Paused" label when the logo is displayed
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index f7d75f8a4..0978be9a8 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
AC_PREREQ(2.52)
-AC_INIT(totem, 0.99.9, http://bugzilla.gnome.org/enter_bug.cgi?product=totem)
+AC_INIT(totem, 0.99.10, http://bugzilla.gnome.org/enter_bug.cgi?product=totem)
AC_CONFIG_SRCDIR(src/totem.c)
AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
AM_CONFIG_HEADER(config.h)
@@ -70,15 +70,13 @@ else
AC_MSG_RESULT(xine)
SAVE_CFLAGS="$CFLAGS"
- CFLAGS="$RHYTHMBOX_CFLAGS"
SAVE_LIBS="$LIBS"
- LIBS="$RHYTHMBOX_LIBS"
AC_TRY_COMPILE([
#include <xine.h>
],[
int arg = 0, foo;
- foo = XINE_PARAM_AUDIO_CLOSE_DEVICE;
- ],(AC_DEFINE(HAVE_XINE_CLOSE,1,[Define if you have the audio device close feature in xine-lib])))
+ foo = XINE_MSG_AUDIO_OUT_UNAVAILABLE;
+ ],,AC_MSG_ERROR(you need at least xine-lib 1.0rc3c installed !))
CFLAGS="$SAVE_CFLAGS"
LIBS="$SAVE_LIBS"
fi