summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2005-01-11 16:06:33 +0000
committerBastien Nocera <hadess@src.gnome.org>2005-01-11 16:06:33 +0000
commit512fc1e9be55cf0d7f60dad3ad09f3334e502089 (patch)
treebedc58fd2a66bc22a1f5e3df54220dcb8a684bd2 /configure.in
parent64a1d101a92645252d7c44d8e49d96f4632a4745 (diff)
downloadtotem-512fc1e9be55cf0d7f60dad3ad09f3334e502089.tar.gz
Port the properties page to the non-bonobo nautilus interface (Closes:
2005-01-11 Bastien Nocera <hadess@hadess.net> * configure.in: * data/Makefile.am: * src/Makefile.am: * src/totem-properties-main.c: (totem_properties_plugin_register_type), (property_page_provider_iface_init), (totem_properties_get_pages), (nautilus_module_initialize), (nautilus_module_shutdown), (nautilus_module_list_types): * src/totem-properties-page.c: * src/totem-properties-view.c: (totem_properties_view_get_type), (totem_properties_view_register_type), (totem_properties_view_class_init), (on_got_metadata_event), (totem_properties_view_init), (totem_properties_view_destroy), (totem_properties_view_new), (totem_properties_view_set_location): * src/totem-properties-view.h: Port the properties page to the non-bonobo nautilus interface (Closes: #162850)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8645a1881..57dc450fb 100644
--- a/configure.in
+++ b/configure.in
@@ -182,6 +182,29 @@ if test x$HAVE_MOZILLA = "xyes"; then
fi
AM_CONDITIONAL(HAVE_MOZILLA, test x$ENABLE_MOZILLA = "xyes")
+dnl Check for Nautilus property page build
+AC_ARG_ENABLE(nautilus,
+ AC_HELP_STRING([--enable-nautilus],[compile the nautilus plugin]),
+ [case "${enableval}" in
+ yes) ENABLE_NAUTILUS=yes ;;
+ no) ENABLE_NAUTILUS=no ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-nautilus) ;;
+ esac],
+ [ENABLE_NAUTILUS=yes]) dnl Default value
+
+if test x$ENABLE_NAUTILUS = "xyes" ; then
+ PKG_CHECK_MODULES(NAUTILUS, gtk+-x11-2.0 $MM gthread-2.0 libnautilus-extension,
+ [HAVE_NAUTILUS=yes], [HAVE_NAUTILUS=no])
+fi
+
+AC_SUBST(NAUTILUS_CFLAGS)
+AC_SUBST(NAUTILUS_LIBS)
+if test x$HAVE_NAUTILUS = "xyes"; then
+ AC_DEFINE(HAVE_NAUTILUS, 1, [defined if you build the nautilus plugin])
+fi
+AM_CONDITIONAL(HAVE_NAUTILUS, test x$ENABLE_NAUTILUS = "xyes")
+
+
dnl LIRC
AC_ARG_ENABLE(lirc,