summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2004-01-07 11:23:30 +0000
committerBastien Nocera <hadess@src.gnome.org>2004-01-07 11:23:30 +0000
commit5a95416e4ceb96b25ede8a51c1d41b148a7deaaa (patch)
tree69c8abea91dd042395e91fef66ebfa80e439cf76 /configure.in
parent3e30eb2292a9d2b5af190b894daed35e6a43866d (diff)
downloadtotem-5a95416e4ceb96b25ede8a51c1d41b148a7deaaa.tar.gz
make vanity optional via --enable-vanity, patch most from Harsh Jaitly
2004-01-07 Bastien Nocera <hadess@hadess.net> * configure.in: * src/Makefile.am: make vanity optional via --enable-vanity, patch most from Harsh Jaitly <hjaitly@novell.com> (Closes: #130467) * src/bvw-test.c: (test_xine_set_mrl), (on_eos_event): fix warnings
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a710e5e03..ff9e134a4 100644
--- a/configure.in
+++ b/configure.in
@@ -74,6 +74,17 @@ fi
AM_CONDITIONAL(TOTEM_GST, test x$ENABLE_GST = "xyes")
+AC_ARG_ENABLE(vanity,
+ AC_HELP_STRING([--enable-vanity],[do not compile and install vanity]),
+ [case "${enableval}" in
+ yes) ENABLE_VANITY=yes ;;
+ no) ENABLE_VANITY=no ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --disable-vanity) ;;
+ esac],
+ [ENABLE_VANITY=yes]) dnl Default value
+
+AM_CONDITIONAL(TOTEM_VANITY, test x$ENABLE_VANITY = "xyes")
+
dnl CURL tests
CURL_MAJOR_REQ=7
CURL_MINOR_REQ=9