summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2007-07-10 00:17:23 +0000
committerBastien Nocera <hadess@src.gnome.org>2007-07-10 00:17:23 +0000
commit2f5181217d98292b6423b4953730c865a363c254 (patch)
tree9a6c241d4349cac40b2a141ac76930ff1b7ece85 /configure.in
parentd251729f3d5b90935a41e938415b7e5d47ee9a0e (diff)
downloadtotem-2f5181217d98292b6423b4953730c865a363c254.tar.gz
Add a number of externally callable functions to allow the Bemused plugin
2007-07-10 Bastien Nocera <hadess@hadess.net> * src/totem-object.c: (totem_get_playlist_length), (totem_get_playlist_pos), (totem_get_title_at_playlist_pos), (totem_get_short_title): * src/totem-playlist.c: (totem_playlist_get_title), (totem_playlist_get_current): * src/totem-playlist.h: * src/totem.c: (totem_get_nice_name_for_stream), (totem_action_set_playlist_index), (totem_action_remote), (totem_action_remote_set_setting), (totem_action_remote_get_setting), (totem_is_paused): * src/totem.h: Add a number of externally callable functions to allow the Bemused plugin to call * configure.in: * src/plugins/bemused/*: Add a Bemused Server plugin svn path=/trunk/; revision=4432
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 5dfc6beb8..d6ff88474 100644
--- a/configure.in
+++ b/configure.in
@@ -64,7 +64,7 @@ AC_SUBST(TOTEM_PL_PARSER_VERSION_MINOR)
AC_SUBST(TOTEM_PL_PARSER_VERSION_MICRO)
# The full list of plugins
-allowed_plugins="screensaver ontop galago gromit lirc media-player-keys properties sidebar-test skipto sample-python sample-vala"
+allowed_plugins="screensaver ontop galago gromit lirc media-player-keys properties sidebar-test skipto sample-python sample-vala bemused"
PLUGINDIR='${libdir}/totem/plugins'
AC_SUBST(PLUGINDIR)
@@ -363,6 +363,13 @@ for plugin in ${used_plugins}; do
add_plugin="0"
fi
;;
+ bemused)
+ PKG_CHECK_MODULES(BEMUSED, bluez, [HAVE_BLUEZ=yes], [HAVE_BLUEZ=no])
+ if test "${HAVE_BLUEZ}" != "yes" ; then
+ plugin_error_or_ignore "you need the bluez libraries installed for the Bemused plugin"
+ add_plugin="0"
+ fi
+ ;;
esac
# Add the specified plugin
@@ -997,6 +1004,7 @@ totem-plparser-uninstalled.pc
lib/Makefile
src/Makefile
src/plugins/Makefile
+src/plugins/bemused/Makefile
src/plugins/screensaver/Makefile
src/plugins/ontop/Makefile
src/plugins/galago/Makefile