summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2007-08-29 15:38:18 +0000
committerBastien Nocera <hadess@src.gnome.org>2007-08-29 15:38:18 +0000
commit9396911fa58a6eea06950bf6c29506189054308b (patch)
tree602afdd8a19a75f9c78aff4a5a8b764b3305182e /configure.in
parent9d972066c6200006947ff24229c28d70fa6085c0 (diff)
downloadtotem-9396911fa58a6eea06950bf6c29506189054308b.tar.gz
Add the Cone plugin, a plugin to mimic the VLC plugin, write IDL files
2007-08-29 Bastien Nocera <hadess@hadess.net> * browser-plugin/Makefile.am: * browser-plugin/idl/Makefile.am: * browser-plugin/idl/totemICone.idl: * browser-plugin/idl/totemIConeAudio.idl: * browser-plugin/idl/totemIConeInput.idl: * browser-plugin/idl/totemIConePlaylist.idl: * browser-plugin/idl/totemIConeVideo.idl: * browser-plugin/totemConePlugin.cpp: * browser-plugin/totemConePlugin.h: * browser-plugin/totemPlugin.cpp: * browser-plugin/totemPluginGlue.h: * configure.in: Add the Cone plugin, a plugin to mimic the VLC plugin, write IDL files from the web developers documentation available on their site (Helps: #462544) * browser-plugin/totemBasicPlugin.h: * browser-plugin/totemComplexPlugin.h: * browser-plugin/totemGMPError.h: * browser-plugin/totemGMPPlugin.h: * browser-plugin/totemMullYPlugin.h: * browser-plugin/totemNarrowSpacePlugin.h: Fix some includes #ifdef svn path=/trunk/; revision=4625
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c7f580f8c..bc0330604 100644
--- a/configure.in
+++ b/configure.in
@@ -670,6 +670,12 @@ AC_ARG_ENABLE([mully-plugin],
[],[enable_mully_plugin=yes])
AC_MSG_RESULT([$enable_mully_plugin])
+AC_MSG_CHECKING([whether to enable the Cone browser plugin])
+AC_ARG_ENABLE([cone-plugin],
+ AS_HELP_STRING([--enable-cone-plugin],[Whether to enable the Cone browser plugin]),
+ [],[enable_cone_plugin=yes])
+AC_MSG_RESULT([$enable_cone_plugin])
+
fi
AM_CONDITIONAL([ENABLE_BASIC_PLUGIN],[test "$enable_basic_plugin" = "yes"])
@@ -677,6 +683,7 @@ AM_CONDITIONAL([ENABLE_GMP_PLUGIN],[test "$enable_gmp_plugin" = "yes"])
AM_CONDITIONAL([ENABLE_COMPLEX_PLUGIN],[test "$enable_complex_plugin" = "yes"])
AM_CONDITIONAL([ENABLE_NARROWSPACE_PLUGIN],[test "$enable_narrowspace_plugin" = "yes"])
AM_CONDITIONAL([ENABLE_MULLY_PLUGIN],[test "$enable_mully_plugin" = "yes"])
+AM_CONDITIONAL([ENABLE_CONE_PLUGIN],[test "$enable_cone_plugin" = "yes"])
dnl ********
dnl Nautilus
@@ -1111,6 +1118,11 @@ if test x$enable_browser_plugins = xyes ; then
else
AC_MSG_NOTICE([ MullY (DivX) plugin disabled])
fi
+ if test x$enable_cone_plugin = xyes ; then
+ AC_MSG_NOTICE([** Cone (VLC) plugin enabled])
+ else
+ AC_MSG_NOTICE([ Cone (VLC) plugin enabled])
+ fi
else
AC_MSG_NOTICE([ Browser plugin disabled])
fi