summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorVasilis Liaskovitis <vliaskov@gmail.com>2012-03-14 22:18:30 +0100
committerBastien Nocera <hadess@hadess.net>2012-03-29 02:51:50 +0200
commit135a476948343f0bce7ce3f6af2919a6696e28ed (patch)
treeab01195e192f65e03ef93b10480c411312db63e8 /configure.in
parent8aa70d5b8e019552271d528e849d68891a029969 (diff)
downloadtotem-135a476948343f0bce7ce3f6af2919a6696e28ed.tar.gz
backend: Implement variable playback rate with pitch adjustment
https://bugzilla.gnome.org/show_bug.cgi?id=417141
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 64dea7426..7957d7b53 100644
--- a/configure.in
+++ b/configure.in
@@ -166,6 +166,21 @@ do
fi
done
+dnl Check for elements from gst-plugins-bad
+for bad_element in pitch
+do
+ AC_MSG_CHECKING([GStreamer 0.10 $bad_element plugin])
+ if $gst010_inspect $bad_element >/dev/null 2>/dev/null; then
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+ AC_MSG_ERROR([
+ Cannot find required GStreamer-0.10 plugin '$bad_element'.
+ It should be part of gst-plugins-bad. Please install it.
+ ])
+ fi
+done
+
dnl Check the smclient backend
AC_MSG_CHECKING([which smclient backend to use])
AC_ARG_WITH([smclient],