summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichal Hruby <michal.mhr@gmail.com>2011-01-29 01:24:05 +0100
committerSiegfried-Angel Gevatter Pujals <rainct@ubuntu.com>2011-02-11 12:39:56 +0100
commitf3e2132a165d855310280569d7da7ae3a50b573c (patch)
tree96285fd26d24ff99c27244dfb4658c32241af802 /configure.in
parent5be9be414e03bca8741e556474ec9179e084c5f0 (diff)
downloadtotem-f3e2132a165d855310280569d7da7ae3a50b573c.tar.gz
Added zeitgeist dataprovider plugin
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c8a0c0853..641f18ffe 100644
--- a/configure.in
+++ b/configure.in
@@ -68,7 +68,7 @@ AC_SUBST(TOTEM_API_VERSION)
AC_DEFINE_UNQUOTED(TOTEM_API_VERSION, ["$TOTEM_API_VERSION"], [Define to the Totem plugin API version])
# The full list of plugins
-allowed_plugins="bemused brasero-disc-recorder chapters coherence_upnp dbus-service galago gromit iplayer jamendo lirc media-player-keys ontop opensubtitles properties publish pythonconsole save-file sample-python sample-vala screensaver screenshot sidebar-test skipto thumbnail tracker youtube"
+allowed_plugins="bemused brasero-disc-recorder chapters coherence_upnp dbus-service galago gromit iplayer jamendo lirc media-player-keys ontop opensubtitles properties publish pythonconsole save-file sample-python sample-vala screensaver screenshot sidebar-test skipto thumbnail tracker youtube zeitgeist-dp"
PLUGINDIR='${libdir}/totem/plugins'
AC_SUBST(PLUGINDIR)
@@ -532,6 +532,19 @@ for plugin in ${used_plugins}; do
add_plugin="0"
fi
;;
+ zeitgeist-dp)
+ if test "${with_vala}" != "yes" ; then
+ plugin_error_or_ignore "you need vala installed to use the zeitgeist-dp plugin"
+ add_plugin="0"
+ else
+ PKG_CHECK_MODULES(LIBZEITGEIST, zeitgeist-1.0 >= 0.2.12,
+ [HAS_LIBZEITGEIST=yes], [HAS_LIBZEITGEIST=no])
+ if test "${HAS_LIBZEITGEIST}" != "yes" ; then
+ plugin_error_or_ignore "you need zeitgeist-1.0 >= 0.2.12 to use the zeitgeist-dp plugin"
+ add_plugin="0"
+ fi
+ fi
+ ;;
esac
# Add the specified plugin
@@ -797,6 +810,7 @@ src/plugins/jamendo/Makefile
src/plugins/jamendo/org.gnome.totem.plugins.jamendo.gschema.xml.in
src/plugins/brasero-disc-recorder/Makefile
src/plugins/chapters/Makefile
+src/plugins/zeitgeist-dp/Makefile
src/backend/Makefile
browser-plugin/Makefile
data/Makefile