summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2019-08-06 12:22:36 +0200
committerBastien Nocera <hadess@hadess.net>2019-08-06 12:24:12 +0200
commit0fd919ba2c5b4c9c805401d9da37b73612c18bb4 (patch)
treebf64734bca8389c0edb2e3162898c99962f36d1c /meson.build
parente80fb563648eaaa314884443ae3c2029f9777e4a (diff)
downloadtotem-0fd919ba2c5b4c9c805401d9da37b73612c18bb4.tar.gz
build: Make introspection non-optional
Introspection was already non-optional as we required a libpeas-gtk build that linked against gobject-introspection-1.0, so that our call to g_irepository_require() was defined. Make that official, and remove the ability to build without introspection. Closes: #346
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build21
1 files changed, 1 insertions, 20 deletions
diff --git a/meson.build b/meson.build
index b66d19bd0..f02ed5336 100644
--- a/meson.build
+++ b/meson.build
@@ -145,17 +145,7 @@ libgd = subproject(
)
libgd_dep = libgd.get_variable('libgd_dep')
-# introspection support
-have_gir = false
-
-introspection_option = get_option('enable-introspection')
-if introspection_option != 'no'
- gir_dep = dependency('gobject-introspection-1.0', version: '>= 0.6.7', required: (introspection_option == 'yes'))
-
- if gir_dep.found()
- have_gir = true
- endif
-endif
+gir_dep = dependency('gobject-introspection-1.0', version: '>= 0.6.7')
# missing plugins support
missing_plugins_deps = []
@@ -202,15 +192,6 @@ if python_option != 'no'
error(str)
endif
message(str + ', disabling Python support')
- else
- if not have_gir
- str = 'Introspection support is required to enable Python plugins'
- if python_option == 'yes'
- error(str)
- endif
- message(str + ', disabling Python support')
- have_python = false
- endif
endif
endif