summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2022-05-24 10:08:58 +0200
committerBastien Nocera <hadess@hadess.net>2022-05-24 13:23:27 +0200
commit2c7772ef4668e2e56b5f4cbf385ac286d363537c (patch)
tree116c426d5c83995d7f4ec93f2709a2529a3ae714 /meson.build
parent4cb04653aea84ac8a2642ea90bb48c4aa5ce4aec (diff)
downloadtotem-2c7772ef4668e2e56b5f4cbf385ac286d363537c.tar.gz
open-directory: Use libportal to open containing folder
This should make the 'Open Containing Folder' functionality carry on working when we've restricted filesystem access further.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 4eb542e09..c960159e3 100644
--- a/meson.build
+++ b/meson.build
@@ -207,6 +207,10 @@ if python_option != 'no'
endif
endif
+# libportal support
+libportal_dep = dependency('libportal-gtk3', required: get_option('libportal'))
+have_libportal = libportal_dep.found()
+
configure_file(
output: 'config.h',
configuration: config_h