summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2022-01-06 17:18:03 +0100
committerBastien Nocera <hadess@hadess.net>2022-01-06 17:22:09 +0100
commit80672c9ae6099e65aed82776c5c413cbd3523909 (patch)
tree99e42c3ed66dbebc840ce376ea0a49d508aea241 /meson.build
parente5ec923676400a2643107f7da1a682f96fdd60ea (diff)
downloadtotem-80672c9ae6099e65aed82776c5c413cbd3523909.tar.gz
build: Add check kwarg to run_command() calls
WARNING: You should add the boolean check kwarg to the run_command call. It currently defaults to false, but it will default to true in future releases of meson. See also: https://github.com/mesonbuild/meson/issues/9300
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index a77fe5077..2322a68a4 100644
--- a/meson.build
+++ b/meson.build
@@ -177,7 +177,7 @@ if python_option != 'no'
if python.found()
python_req_version = '>= 3.0'
- r = run_command([python, '--version'])
+ r = run_command([python, '--version'], check: true)
python_version = r.stdout().split(' ')[1]
pygobject_dep = dependency('pygobject-3.0', version: '>= 2.90.3', required: false)