summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2019-02-07 14:03:02 +0100
committerBastien Nocera <hadess@hadess.net>2019-02-07 14:06:46 +0100
commitdb195282d8389d473da3056b8a7cca02cc56111a (patch)
tree56f4fad52d7eb93223cc0ababdae8a2ba1c5fde9 /meson.build
parentdf42b9eaf7306b4159edc8fd1046f727bbaa95db (diff)
downloadtotem-db195282d8389d473da3056b8a7cca02cc56111a.tar.gz
build: Python support requires introspection support
So error out if Python support is requested but introspection isn't available, or disable Python support if not explicitely enabled. The Vala support portion of the build system already has similar code. Closes: #238
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d46de94c0..e9266cf2c 100644
--- a/meson.build
+++ b/meson.build
@@ -206,6 +206,15 @@ if python_option != 'no'
error(str)
endif
message(str + ', disabling Python support')
+ else
+ if not have_gir
+ str = 'Introspection support is required to enable Python plugins'
+ if python_option == 'yes'
+ error(str)
+ endif
+ message(str + ', disabling Python support')
+ have_python = false
+ endif
endif
endif