summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2018-02-15 14:08:17 +0100
committerIñigo Martínez <inigomartinez@gmail.com>2018-03-01 15:08:56 +0100
commit3c076201bc49f64ee3e7c6a00b962d6e14c29317 (patch)
tree2ba4b11067f66098d8f102727d3249037778a3b3 /meson.build
parent522531e7d2f22329739f7bef5b816813b478d365 (diff)
downloadtotem-3c076201bc49f64ee3e7c6a00b962d6e14c29317.tar.gz
build: Remove unnecessary variables and defines
There are a number of variables and defines that were available in autotools and were ported to meson that are actually not necessary. Anything unnecessary has been removed.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build45
1 files changed, 14 insertions, 31 deletions
diff --git a/meson.build b/meson.build
index acbc7abed..aa3267ac6 100644
--- a/meson.build
+++ b/meson.build
@@ -13,9 +13,6 @@ totem_minor_version = version_array[1].to_int()
totem_micro_version = version_array[2].to_int()
totem_api_version = '1.0'
-api_version_array = totem_version.split('.')
-totem_api_major_version = api_version_array[0].to_int()
-totem_api_minor_version = api_version_array[1].to_int()
totem_api_path = join_paths(meson.project_name(), totem_api_version)
@@ -48,36 +45,23 @@ cc = meson.get_compiler('c')
config_h = configuration_data()
-config_h.set_quoted('GETTEXT_PACKAGE', meson.project_name())
-
# debug options
config_h.set('GNOME_ENABLE_DEBUG', totem_buildtype != 'release',
description: 'Define if debugging is enabled')
-config_h.set('NDEBUG', totem_buildtype == 'release',
- description: 'Define if debugging is disabled')
-
-# package
-config_h.set_quoted('PACKAGE', meson.project_name())
-config_h.set_quoted('PACKAGE_BUGREPORT', 'http://bugzilla.gnome.org/enter_bug.cgi?product=totem')
-config_h.set_quoted('PACKAGE_NAME', meson.project_name())
-config_h.set_quoted('PACKAGE_STRING', '@0@ @1@'.format(meson.project_name(), totem_version))
-config_h.set_quoted('PACKAGE_TARNAME', meson.project_name())
-config_h.set_quoted('PACKAGE_URL', 'https://wiki.gnome.org/Apps/Videos')
-config_h.set_quoted('PACKAGE_VERSION', totem_version)
-config_h.set_quoted('TOTEM_API_VERSION', totem_api_version)
-config_h.set_quoted('VERSION', totem_version)
-
-# headers
-config_h.set('HAVE_DLFCN_H', cc.has_header('dlfcn.h'))
-config_h.set('HAVE_INTTYPES_H', cc.has_header('inttypes.h'))
-config_h.set('HAVE_MEMORY_H', cc.has_header('memory.h'))
-config_h.set('HAVE_STDINT_H', cc.has_header('stdint.h'))
-config_h.set('HAVE_STDLIB_H', cc.has_header('stdlib.h'))
-config_h.set('HAVE_STRINGS_H', cc.has_header('strings.h'))
-config_h.set('HAVE_STRING_H', cc.has_header('string.h'))
-config_h.set('HAVE_SYS_STAT_H', cc.has_header('sys/stat.h'))
-config_h.set('HAVE_SYS_TYPES_H', cc.has_header('sys/types.h'))
-config_h.set('HAVE_UNISTD_H', cc.has_header('unistd.h'))
+
+# defines
+set_defines = [
+ # package
+ ['PACKAGE', meson.project_name()],
+ ['TOTEM_API_VERSION', totem_api_version],
+ ['VERSION', totem_version],
+ # i18n
+ ['GETTEXT_PACKAGE', meson.project_name()]
+]
+
+foreach define: set_defines
+ config_h.set_quoted(define[0], define[1])
+endforeach
# Compiler flags
common_flags = [
@@ -272,7 +256,6 @@ if get_option('enable-nautilus') != 'no'
nautilusdir = libnautilus_ext_dep.get_pkgconfig_variable('extensiondir')
endif
- config_h.set('HAVE_NAUTILUS', true)
have_nautilus = true
message('installing nautilus plugin in ' + nautilusdir)
else