summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2018-06-27 15:41:38 +0200
committerBastien Nocera <hadess@hadess.net>2018-06-27 15:41:38 +0200
commit7f54e1f0369cf2087655ab3e7fd071440d3f867f (patch)
treed8763fc9ccdd1ab1e4e3b72959f3e060b88f0a94 /meson.build
parenta1250298555107734bbe7fdcb7e566197e2c4117 (diff)
downloadtotem-7f54e1f0369cf2087655ab3e7fd071440d3f867f.tar.gz
build: Fix error before error when vala is missing
Instead of: str = 'you need vala ' + vala_req_version + ' installed to use vala plugins' you'd get: meson.build:225:6: ERROR: Unknown variable "vala_req_version". because vala_req_version isn't defined in the right scope.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 47b0cb846..3653e92c0 100644
--- a/meson.build
+++ b/meson.build
@@ -214,8 +214,8 @@ have_vala = false
vala_option = get_option('enable-vala')
if vala_option != 'no'
if have_gir
+ vala_req_version = '>= 0.14.1'
if add_languages('vala', required: false)
- vala_req_version = '>= 0.14.1'
if meson.get_compiler('vala').version().version_compare(vala_req_version)
have_vala = true
endif