summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2018-06-14 15:35:45 +0200
committerBastien Nocera <hadess@hadess.net>2018-06-14 16:44:05 +0200
commitfdb57851121ec9441248c8076e505b084cffd62e (patch)
tree2d3ae3873086daf919579a5dce5b1b83b3638b20 /meson.build
parent5de3b72cb3a5e083f7eca83114cd77c4a9c70349 (diff)
downloadtotem-fdb57851121ec9441248c8076e505b084cffd62e.tar.gz
build: Make pylint optional
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index aa403762a..cea363593 100644
--- a/meson.build
+++ b/meson.build
@@ -192,7 +192,7 @@ if python_option != 'no'
pygobject_dep = dependency('pygobject-3.0', version: '>= 2.90.3', required: false)
pylint = find_program('pylint-3', 'pylint3', 'pylint', required: false)
- if python_version.version_compare(python_req_version) and pygobject_dep.found() and pylint.found()
+ if python_version.version_compare(python_req_version) and pygobject_dep.found()
have_python = true
python_deps += pygobject_dep
meson.add_install_script('meson_compile_python.py')
@@ -200,7 +200,7 @@ if python_option != 'no'
endif
if not have_python
- str = 'python ' + python_req_version + ', pygobject or pylint not found'
+ str = 'python ' + python_req_version + ', pygobject not found'
if python_option == 'yes'
error(str)
endif