summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2017-08-10 11:01:36 +0200
committerBastien Nocera <hadess@hadess.net>2017-08-10 11:16:16 +0200
commitd125affbc2e792d8cc626db964bcf5d57c7bb85e (patch)
tree83991b62eb4a5a07fb25566d723deabc9a330f71 /meson.build
parent18697d303d0cb9a0177167e0fc8b98722e19717c (diff)
downloadtotem-d125affbc2e792d8cc626db964bcf5d57c7bb85e.tar.gz
build: Check for alternative pylint names first
So that weirdly named Python3-enabled pylint are detected first, before we fallback to "pylint". https://bugzilla.gnome.org/show_bug.cgi?id=786082
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c041657f1..69cd2a131 100644
--- a/meson.build
+++ b/meson.build
@@ -219,7 +219,7 @@ if python_option != 'no'
python_version = r.stdout().split(' ')[1]
pygobject_dep = dependency('pygobject-3.0', version: '>= 2.90.3', required: false)
- pylint = find_program('pylint', required: false)
+ pylint = find_program('pylint-3', 'pylint3', 'pylint', required: false)
if python_version.version_compare(python_req_version) and pygobject_dep.found() and pylint.found()
have_python = true