summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2018-07-31 13:35:47 +0200
committerBastien Nocera <hadess@hadess.net>2018-07-31 13:41:37 +0200
commit57a0d2af92eeb15030388d9cf725ad04ec31bb9d (patch)
tree6757dd670a651f555bb77bacd3a3f89d03b9ab00 /meson.build
parent71c65fe73a8b23d638f68ce0a85562a049e5b302 (diff)
downloadtotem-57a0d2af92eeb15030388d9cf725ad04ec31bb9d.tar.gz
build: Add missing gio-unix-2.0 dep
For the missing plugins feature. Closes: #246
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 3653e92c0..c0679d25e 100644
--- a/meson.build
+++ b/meson.build
@@ -169,9 +169,10 @@ if easy_codec_option != 'no'
gst_pbutils_dep = dependency('gstreamer-pbutils-1.0', required: (easy_codec_option == 'yes'))
if gst_pbutils_dep.found()
have_easy_codec = true
+ gio_unix_dep = dependency('gio-unix-2.0')
endif
- missing_plugins_deps += gst_pbutils_dep
+ missing_plugins_deps += [ gst_pbutils_dep, gio_unix_dep ]
config_h.set('ENABLE_MISSING_PLUGIN_INSTALLATION', have_easy_codec,
description: 'Whether we can and want to do installation of missing plugins')
endif