summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2022-08-23 21:35:44 -0400
committerBastien Nocera <hadess@hadess.net>2022-08-24 08:36:16 +0000
commit09e76c5d35ff6e2e100d3a5e2eb6fa940dae2fb2 (patch)
treea7316540541e72663c6906f52fc17a1d2a41f0ec /meson.build
parent06b428644ae50523c9cef4049464b4ac02d49858 (diff)
downloadtotem-09e76c5d35ff6e2e100d3a5e2eb6fa940dae2fb2.tar.gz
build: Use GNOME module post_install()
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 0c871dd10..a8c0ce5ec 100644
--- a/meson.build
+++ b/meson.build
@@ -3,7 +3,7 @@ project(
version: '43.beta',
license: 'GPL2+ with exception',
default_options: 'buildtype=debugoptimized',
- meson_version: '>= 0.50.0'
+ meson_version: '>= 0.57.0'
)
totem_version = meson.project_version()
@@ -235,7 +235,10 @@ if get_option('enable-gtk-doc')
subdir('docs/reference')
endif
-meson.add_install_script('meson_post_install.py')
+gnome.post_install(
+ glib_compile_schemas: true,
+ gtk_update_icon_cache: true,
+)
is_stable = (totem_minor_version != 'alpha' and
totem_minor_version != 'beta' and