summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2021-04-30 21:56:32 +0200
committerBastien Nocera <hadess@hadess.net>2021-05-06 12:50:36 +0200
commit3883891dd47e8ac98ac696d62a0384bc32ef4b10 (patch)
treec27b0d0967b81876e0e0f2107e999fb613b6c739 /meson.build
parente1a6447d9f824e20d083c8de792be3fe5af1c53d (diff)
downloadtotem-3883891dd47e8ac98ac696d62a0384bc32ef4b10.tar.gz
build: Bump version number
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 5 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 078de15a8..29aef7465 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,6 @@
project(
'totem', 'c',
- version: '3.38.0',
+ version: '41.alpha.0',
license: 'GPL2+ with exception',
default_options: 'buildtype=debugoptimized',
meson_version: '>= 0.50.0'
@@ -9,7 +9,7 @@ project(
totem_version = meson.project_version()
version_array = totem_version.split('.')
totem_major_version = version_array[0].to_int()
-totem_minor_version = version_array[1].to_int()
+totem_minor_version = version_array[1]
totem_micro_version = version_array[2].to_int()
totem_api_version = '1.0'
@@ -225,7 +225,9 @@ endif
meson.add_install_script('meson_post_install.py')
-is_stable = totem_minor_version.is_even()
+is_stable = (totem_minor_version != 'alpha' and
+ totem_minor_version != 'beta' and
+ totem_minor_version != 'rc')
if is_stable
meson.add_dist_script(
find_program('check-news.sh').path(),