summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2019-02-11 21:43:50 +0100
committerBastien Nocera <hadess@hadess.net>2019-02-18 18:46:21 +0000
commitc16667364bcc0ee1e683a7516f62031b5d75e6fa (patch)
tree657b4e9d0ad7d0238cd03b78c6a8b96999c725d9 /meson.build
parentbb8b899a11b1fecffd9d50d1453961628a5a3b5f (diff)
downloadtotem-c16667364bcc0ee1e683a7516f62031b5d75e6fa.tar.gz
build: Fix obsolescence warning with Python 3 check
DEPRECATION: Project targetting '>= 0.43.0' but tried to use feature deprecated since '0.48.0': python3 module
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index ebba26438..aea893764 100644
--- a/meson.build
+++ b/meson.build
@@ -3,7 +3,7 @@ project(
version: '3.31.90',
license: 'GPL2+ with exception',
default_options: 'buildtype=debugoptimized',
- meson_version: '>= 0.43.0'
+ meson_version: '>= 0.46.0'
)
totem_version = meson.project_version()
@@ -181,7 +181,7 @@ python_deps = []
python_option = get_option('enable-python')
if python_option != 'no'
- python = import('python3').find_python()
+ python = import('python').find_installation('python3')
if python.found()
python_req_version = '>= 3.0'