summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2019-09-28 15:11:00 +0200
committerBastien Nocera <hadess@hadess.net>2019-09-28 15:16:28 +0200
commitf6ca692f352f05d59d3de69e058c329a612f9523 (patch)
tree4d070cc76b8fac568990a7f312eeed26323db8a7 /meson.build
parent56256ceabdc09d309be369f626a14535dcf262d5 (diff)
downloadtotem-f6ca692f352f05d59d3de69e058c329a612f9523.tar.gz
build: Simplify missing plugins build option
gio-unix-2.0 hasn't been a dependency for that piece of code since the move to gnome-software and its D-Bus API, and the gst-plugins-base utils header was required, so remove the dependencies from that option.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 1 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index bd4e87d72..6e7dea88a 100644
--- a/meson.build
+++ b/meson.build
@@ -159,17 +159,10 @@ libgd_dep = libgd.get_variable('libgd_dep')
gir_dep = dependency('gobject-introspection-1.0', version: '>= 0.6.7')
# missing plugins support
-missing_plugins_deps = []
-
easy_codec_option = get_option('enable-easy-codec-installation')
have_easy_codec = false
if easy_codec_option != 'no'
- if gst_pbutils_dep.found()
- have_easy_codec = true
- gio_unix_dep = dependency('gio-unix-2.0')
- endif
-
- missing_plugins_deps += [ gst_pbutils_dep, gio_unix_dep ]
+ have_easy_codec = true
endif
config_h.set('ENABLE_MISSING_PLUGIN_INSTALLATION', have_easy_codec,
description: 'Whether we can and want to do installation of missing plugins')