summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2019-02-11 16:01:07 +0100
committerBastien Nocera <hadess@hadess.net>2019-02-11 16:30:46 +0100
commit10c452c42c22654f0ac7f121b0036334c178b6b7 (patch)
treeb6e5e42bc7fdfdba0dd1f0615656d31360f79767 /meson.build
parent3d68ae5e619c3f847a8896a0f51828f970742381 (diff)
downloadtotem-10c452c42c22654f0ac7f121b0036334c178b6b7.tar.gz
properties: Remove nautilus properties page
It's now in nautilus itself. See: https://gitlab.gnome.org/GNOME/nautilus/issues/887 https://gitlab.gnome.org/GNOME/nautilus/merge_requests/411
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build29
1 files changed, 0 insertions, 29 deletions
diff --git a/meson.build b/meson.build
index e7c878652..1a2ef09b6 100644
--- a/meson.build
+++ b/meson.build
@@ -216,28 +216,6 @@ if python_option != 'no'
endif
endif
-# nautilus support
-have_nautilus = false
-
-if get_option('enable-nautilus') != 'no'
- libnautilus_ext_dep = dependency('libnautilus-extension', version: '>= 2.91.3', required: false)
- if libnautilus_ext_dep.found()
- nautilusdir = get_option('with-nautilusdir')
- if nautilusdir == ''
- nautilusdir = libnautilus_ext_dep.get_pkgconfig_variable('extensiondir')
- endif
-
- have_nautilus = true
- message('installing nautilus plugin in ' + nautilusdir)
- else
- if get_option('enable-nautilus') == 'yes'
- error('nautilus support enabled but libnautilus-extension missing')
- else
- message('libnautilus-extension missing so disabling nautilus supportt')
- endif
- endif
-endif
-
configure_file(
output: 'config.h',
configuration: config_h
@@ -287,11 +265,4 @@ foreach plugin: allowed_plugins
endif
endforeach
-str = 'Nautilus properties page'
-if have_nautilus
- message('** ' + str + ' enabled')
-else
- message(' ' + str + ' disabled')
-endif
-
message('End options')