summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2020-09-01 10:46:22 +0200
committerBastien Nocera <hadess@hadess.net>2020-09-01 10:46:22 +0200
commit1f98dab98efbde9e116733693a446267e8911f61 (patch)
treeb89430f83b8598c1e9f92b0352bbea362c786fed /meson.build
parent3e1d95332ab877bd43530818d7e4f0804a30280f (diff)
downloadtotem-1f98dab98efbde9e116733693a446267e8911f61.tar.gz
build: Don't require update appdata for devel releases3.37.90
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build21
1 files changed, 15 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 99f610000..8cea90960 100644
--- a/meson.build
+++ b/meson.build
@@ -223,12 +223,21 @@ endif
meson.add_install_script('meson_post_install.py')
-meson.add_dist_script(
- find_program('check-news.sh').path(),
- '@0@'.format(meson.project_version()),
- 'NEWS',
- 'data/appdata/org.gnome.Totem.appdata.xml.in'
-)
+is_stable = totem_minor_version.is_even()
+if is_stable
+ meson.add_dist_script(
+ find_program('check-news.sh').path(),
+ '@0@'.format(meson.project_version()),
+ 'NEWS',
+ 'data/appdata/org.gnome.Totem.appdata.xml.in'
+ )
+else
+ meson.add_dist_script(
+ find_program('check-news.sh').path(),
+ '@0@'.format(meson.project_version()),
+ 'NEWS',
+ )
+endif
message('Totem was configured with the following options:')
message('** Using the GStreamer-1.0 backend')