summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJeremy Bicha <jbicha@ubuntu.com>2017-08-10 00:05:28 -0400
committerBastien Nocera <hadess@hadess.net>2017-08-10 11:16:16 +0200
commit54e7c7f7e2a01b5d9fbcc4fe5b9b86ea4f16dfa3 (patch)
tree73024c45678629b106abfbc5f52e260dbd98ddf9 /meson.build
parentd125affbc2e792d8cc626db964bcf5d57c7bb85e (diff)
downloadtotem-54e7c7f7e2a01b5d9fbcc4fe5b9b86ea4f16dfa3.tar.gz
build: Fix failure when not building a debug version
Meson encountered an error in file src/backend/meson.build, line 90, column 0: Unknown variable "warn_flags". The warn_flags would not be initialised when the build was not a debug build. Initialise the variable outside the debug conditional. https://bugzilla.gnome.org/show_bug.cgi?id=786083
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 69cd2a131..a93d821af 100644
--- a/meson.build
+++ b/meson.build
@@ -105,6 +105,8 @@ common_flags = [
'-DLIBSOUP_DISABLE_SINGLE_INCLUDES'
]
+warn_flags = []
+
if totem_buildtype == 'debug' or totem_buildtype == 'debugoptimized'
test_cflags = [
'-fno-strict-aliasing',
@@ -132,8 +134,6 @@ if totem_buildtype == 'debug' or totem_buildtype == 'debugoptimized'
'-Wstrict-prototypes'
]
- warn_flags = []
-
foreach cflag: test_cflags
if cc.has_argument(cflag)
warn_flags += [cflag]