summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2021-05-05 00:00:07 -0300
committerBastien Nocera <hadess@hadess.net>2021-06-29 17:19:33 +0200
commite23c46619ae1996d237e27b75ba80cc2ec23be34 (patch)
tree9df2577173c45b29112bcaa99ba39f2534c2da5c /src/meson.build
parent75e982fc10ba5d3463a1320c0d3cde7bd0ac6f54 (diff)
downloadtotem-e23c46619ae1996d237e27b75ba80cc2ec23be34.tar.gz
preferences: Embed preferences.ui as a GResource
Instead of installing preferences.ui and opening the file, embed it as a GResource and load it using gtk_builder_new_from_resource(). We don't need extra caution because the file is now guaranteed to be embedded into the application. This will be very handy for the next commit where we start using a GtkBuilder template for the preferences dialog.
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index 1ad816adf..6b359d633 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -137,6 +137,8 @@ libtotem_sources += gnome.compile_resources(
c_name: '_totem'
)
+libtotem_sources += ui_resources
+
libtotem_deps = [
libtotem_player_dep,
libbacon_video_widget_dep,