summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c1bf4cde7..8645a1881 100644
--- a/configure.in
+++ b/configure.in
@@ -15,6 +15,17 @@ AC_PROG_CXX
AC_PROG_LIBTOOL()
AC_PROG_INTLTOOL([0.20])
+# Before making a release, the PLPARSER_LT_VERSION string should be modified.
+# The string is of the form C:R:A.
+# - If interfaces have been changed or added, but binary compatibility has
+# been preserved, change to C+1:0:A+1
+# - If binary compatibility has been broken (eg removed or changed interfaces)
+# change to C+1:0:0
+# - If the interface is the same as the previous version, change to C:R+1:A
+PLPARSER_LT_VERSION=0:0:0
+AC_SUBST(PLPARSER_LT_VERSION)
+
+
AC_ARG_ENABLE(nvtv, AC_HELP_STRING([--enable-nvtv],[Enable support for TV-output with nvtv]), enable_nvtv="$enableval", enable_nvtv=yes)
if test x$enable_nvtv = xyes; then
@@ -289,6 +300,13 @@ AM_CONDITIONAL(HAVE_X86, `test "x$_system_is_x86" = "xyes" && test "x$CURL_CONFI
AC_PATH_PROG(GCONFTOOL, gconftool-2)
AM_GCONF_SOURCE_2
+dnl check for glib (defines GLIB_MKENUMS)
+AM_PATH_GLIB_2_0
+dnl Check for packages for building libtotem-plparser.la
+PKG_CHECK_MODULES(TOTEM_PLPARSER, [gtk+-2.0 libxml-2.0 gnome-vfs-2.0
+ gnome-vfs-module-2.0])
+
+
dnl debug
AC_ARG_ENABLE(debug,
AC_HELP_STRING([--disable-debug],[disables compilation of debugging messages]),
@@ -319,6 +337,7 @@ AM_GLIB_GNU_GETTEXT
AC_OUTPUT([
Makefile
totem.spec
+totem-plparser.pc
src/Makefile
data/Makefile
data/totem.desktop.in.in