summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 0c871dd10..a8c0ce5ec 100644
--- a/meson.build
+++ b/meson.build
@@ -3,7 +3,7 @@ project(
version: '43.beta',
license: 'GPL2+ with exception',
default_options: 'buildtype=debugoptimized',
- meson_version: '>= 0.50.0'
+ meson_version: '>= 0.57.0'
)
totem_version = meson.project_version()
@@ -235,7 +235,10 @@ if get_option('enable-gtk-doc')
subdir('docs/reference')
endif
-meson.add_install_script('meson_post_install.py')
+gnome.post_install(
+ glib_compile_schemas: true,
+ gtk_update_icon_cache: true,
+)
is_stable = (totem_minor_version != 'alpha' and
totem_minor_version != 'beta' and