summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index 6446e603e..3185cea50 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -118,6 +118,7 @@ libtotem_sources = files(
'totem-open-location.c',
'totem-options.c',
'totem-playlist.c',
+ 'totem-playlist-inspector-page.c',
'totem-preferences-dialog.c',
'totem-search-entry.c',
'totem-selection-toolbar.c',
@@ -262,6 +263,22 @@ executable(
c_args: totem_common_cflags
)
+if get_option('inspector-page')
+ module_libdir = totem_libdir / 'gtk-3.0' / 'inspector'
+
+ totem_inspector_sources = [
+ 'totem-inspector-module.c',
+ ]
+
+ shared_module(
+ 'totem-inspector-module',
+ totem_inspector_sources,
+ dependencies: libtotem_player_dep,
+ install: true,
+ install_dir: module_libdir,
+ )
+endif
+
gir_sources = libtotem_sources + libtotem_player_sources + headers
gir_incs = [