summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/meson.build b/src/meson.build
index 6e3a334bb..b74fc1a6c 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -53,9 +53,9 @@ totem_common_incs = [
totem_common_deps = libbacon_video_widget_deps + python_deps + [
glib_dep,
gio_dep,
+ gmodule_dep,
gtk_dep,
hdy_dep,
- dependency('gmodule-2.0'),
totem_plparser_dep,
gir_dep,
peas_dep,
@@ -189,7 +189,7 @@ totem = executable(
meson.project_name(),
'totem.c',
include_directories: totem_common_incs,
- dependencies: libtotem_dep,
+ dependencies: [ libtotem_dep, x11_dep ],
c_args: totem_common_cflags + [
'-DG_LOG_DOMAIN="Totem"'
],