summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarlos Garnacho <carlosg@gnome.org>2019-12-10 13:14:43 +0100
committerCarlos Garnacho <carlosg@gnome.org>2019-12-10 13:37:21 +0100
commit3900adfcd03e1f196cfd65db37827648e200bfc3 (patch)
tree0f5a2f64eb2a76fffb633e00addc3e558f3c900f /meson.build
parentec4b446e7a3b80490106d1f9ef08a3b820e4f0e2 (diff)
downloadtracker-3900adfcd03e1f196cfd65db37827648e200bfc3.tar.gz
build: Mark sqlite 3.24.0 >= $version >= 3.28.0 as broken
This range of versions break ontology updates, in combination with the newer technique to implement the union graph through WITH clause queries. The previous and following working versions are 3.23.1 and 3.29.0.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 77b2ddb69..aff14b15c 100644
--- a/meson.build
+++ b/meson.build
@@ -343,6 +343,9 @@ if not get_option('override_sqlite_version_check')
elif sqlite.version().version_compare('3.8.4.2')
error(template.format('3.8.4.2',
'https://mail.gnome.org/archives/tracker-list/2014-April/msg00001.html'))
+ elif sqlite.version().version_compare('>= 3.24.0') and sqlite.version().version_compare('<= 3.28.0')
+ error(template.format('>=3.24.0, <= 3.28.0',
+ 'https://gitlab.gnome.org/GNOME/tracker/merge_requests/160#note_664713'))
endif
endif