summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSam Thursfield <sam@afuera.me.uk>2019-07-10 15:07:48 +0100
committerSam Thursfield <sam@afuera.me.uk>2019-07-10 15:07:48 +0100
commitaef285b4a801ba7e9d8c166c668b27713e241130 (patch)
tree570f10f5ec9d61d9709d01574b5269d2483b4ad1 /meson.build
parenta92309f9cf9099a8b0b54908e032dcb181ab6c63 (diff)
downloadtracker-aef285b4a801ba7e9d8c166c668b27713e241130.tar.gz
build: Compile GSettings schemas after install
This isn't needed in the common case of distro package builds, as the distro package will already provide a hook. However, our README.md tells developers to install into a prefix like ~/opt/tracker, and that is broken by default because GLib will complain that none of the settings schemas are installed.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 92da1240b..7bfa10ec2 100644
--- a/meson.build
+++ b/meson.build
@@ -330,6 +330,7 @@ tracker_ontologies_dir = join_paths(get_option('prefix'), get_option('datadir'),
vapi_dir = join_paths(get_option('prefix'), get_option('datadir'), 'vala', 'vapi')
+glib_compile_schemas = find_program('glib-compile-schemas')
glib_mkenums = find_program('glib-mkenums')
g_ir_compiler = find_program('g-ir-compiler', gobject_introspection.get_pkgconfig_variable('g_ir_compiler'))
g_ir_merge = find_program('g-ir-merge', join_paths(meson.current_source_dir(), 'utils', 'g-ir-merge', 'g-ir-merge'))
@@ -374,6 +375,8 @@ elif sqlite.version().version_compare('3.8.4.2')
sqlite_safe = false
endif
+meson.add_install_script('meson_integration_commands.sh', glib_compile_schemas.path(), gsettings_schema_dir)
+
summary = [
'\nBuild Configuration:',
' Prefix: ' + get_option('prefix'),