summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSam Thursfield <sam@afuera.me.uk>2019-08-27 00:04:11 +0300
committerSam Thursfield <sam@afuera.me.uk>2019-09-14 12:09:19 +0200
commitdae63fea40d9b045bca0e39e855ee61c456e944d (patch)
treed93ddb230236e60e56618bc236879071a980dc6c /meson.build
parent2d9c4449ed908214268e23aa5bf7c77cc2cf8601 (diff)
downloadtracker-dae63fea40d9b045bca0e39e855ee61c456e944d.tar.gz
functional-tests: Start daemons through D-Bus autolaunch
Instead of manually running and managing Tracker daemon processes manually in the test, we now rely on our private D-Bus daemon to do so. This makes the test environment more like a real Tracker deployment. Log output from the D-Bus daemon is now captured and output through the Python logging system. This allows for finer-grained filtering of output from the tests themselves and from the Tracker daemons. Some test code is changed to support the new model.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 0 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 5b30c1982..d6c2fa4a6 100644
--- a/meson.build
+++ b/meson.build
@@ -283,10 +283,6 @@ conf.set('tracker_store', join_paths ('${libexecdir}', 'tracker-store'))
conf.set('ontologies_dir', join_paths ('${datadir}', 'tracker', 'ontologies'))
conf.set('domain_ontologies_dir', join_paths('${datadir}', 'tracker', 'domain-ontologies'))
-# Configure functional tests to run completely from source tree.
-conf.set('FUNCTIONAL_TESTS_ONTOLOGIES_DIR', join_paths(meson.current_source_dir(), 'tests', 'functional-tests', 'test-ontologies'))
-conf.set('FUNCTIONAL_TESTS_TRACKER_STORE_PATH', join_paths(meson.current_build_dir(), 'src', 'tracker-store', 'tracker-store'))
-
configure_file(input: 'config.h.meson.in',
output: 'config.h',
configuration: conf)