summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSam Thursfield <sam@afuera.me.uk>2019-08-31 03:20:05 +0300
committerSam Thursfield <sam@afuera.me.uk>2019-09-14 12:09:19 +0200
commite13d9087af7ce4c601c4c2a4bda4083960eaf0c0 (patch)
tree118c3feee8aa0d279bd87e9a9671c5595f5b1725 /meson.build
parent12f095cc07d921c06a666aef05ab3f37b58804ad (diff)
downloadtracker-e13d9087af7ce4c601c4c2a4bda4083960eaf0c0.tar.gz
Expose dbus_services_dir to dependent projects
The tracker-miners tests now depend on the tests/services/org.freedesktop.Tracker1.service file. We need to expose it. The pkg-config variable is for situations where we build against an installed Tracker core (so we use the normal service file, and honour any custom location that the user specified for it). The Meson variable is for when Tracker core is built as a subproject of tracker-miners.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d6c2fa4a6..af7ad6bc7 100644
--- a/meson.build
+++ b/meson.build
@@ -273,6 +273,7 @@ conf.set('exec_prefix', get_option('prefix'))
conf.set('bindir', join_paths(get_option('prefix'), get_option('bindir')))
conf.set('datadir', datadir)
conf.set('datarootdir', join_paths(get_option('prefix'), get_option('datadir')))
+conf.set('dbus_services_dir', dbus_services_dir)
conf.set('includedir', join_paths(get_option('prefix'), get_option('includedir')))
conf.set('libdir', libdir)
conf.set('libexecdir', join_paths(get_option('prefix'), get_option('libexecdir')))