summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarlos Garnacho <carlosg@gnome.org>2020-02-23 13:27:41 +0100
committerCarlos Garnacho <carlosg@gnome.org>2020-04-05 14:28:34 +0200
commitfcb95bc250e1ad18d74e977c3a22f1899d82e939 (patch)
tree80ecca17d93a31c99e9a502a2d14bb3d1a4bf09c /meson.build
parente89d6a6bc89832983e24adc78cacfb845974b16b (diff)
downloadtracker-fcb95bc250e1ad18d74e977c3a22f1899d82e939.tar.gz
build: Add tracker_api_major and tracker_versioned_name definitions
That would be "3" and "tracker-3" for the upcoming 3.0 series.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 0374797f3..6d233a276 100644
--- a/meson.build
+++ b/meson.build
@@ -9,6 +9,8 @@ cc = meson.get_compiler('c')
# This is the X.Y used in -llibtracker-FOO-X.Y
tracker_api_version = '3.0'
+tracker_api_major = tracker_api_version.split('.')[0]
+tracker_versioned_name = 'tracker-@0@'.format(tracker_api_major)
tracker_version = meson.project_version().split('-')[0]
tracker_major_version = tracker_version.split('.')[0].to_int()