summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSam Thursfield <sam@afuera.me.uk>2019-12-04 20:34:38 +0100
committerSam Thursfield <sam@afuera.me.uk>2019-12-04 20:54:27 +0100
commit186bcaf1de91074a18659d9e850589598dd744f0 (patch)
treee7e8d782aea8463a405df2b037889f29769ed846 /meson.build
parent13e0d64143ea6cc1348156501306c991bde054a0 (diff)
downloadtracker-186bcaf1de91074a18659d9e850589598dd744f0.tar.gz
Remove libuuid dependency, bump GLib requirement to >= 2.52.0
The functionality that we were using from libuuid is now present in GLib itself. Fixes https://gitlab.gnome.org/GNOME/tracker/issues/131
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 1 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index 376c0784c..844e4728e 100644
--- a/meson.build
+++ b/meson.build
@@ -24,7 +24,7 @@ libversion = '@0@.@1@.@2@'.format(soversion, tracker_binary_age - tracker_interf
libdir = join_paths(get_option('prefix'), get_option('libdir'))
datadir = join_paths(get_option('prefix'), get_option('datadir'))
-glib_required = '2.46.0'
+glib_required = '2.52.0'
# 3.6.11 for sqlite_backup API
# 3.6.16 to fix test failures
@@ -51,14 +51,6 @@ sqlite = dependency('sqlite3', version: '>' + sqlite_required)
libmath = cc.find_library('m', required: false)
-# FIXME: here we work around a quirk todo with Meson and Vala: the 'uuid'
-# pkg-config component corresponds to 'libuuid.vapi', but Meson assumes that
-# .vapi name always matches pkg-config name, and will add `--pkg uuid` to the
-# Vala commandline. By finding 'uuid' using find_library() instead, we get
-# a dependency object back that won't cause any `--pkg` arguments to be added
-# to the Vala commandline, but still works as expected for C code.
-uuid = cc.find_library('uuid')
-
add_project_arguments('-Wformat', '-Wformat-security', language: 'c')
# There are various gchar vs. unsigned char warnings that occur in extract