summaryrefslogtreecommitdiff
path: root/src/tracker-extract/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2015-09-28 13:48:29 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2016-05-16 10:59:02 +0100
commit44eed827e27895a46f08f57693b859674cb7d141 (patch)
tree5194ac5c38a73d2a8ce35f1aa5662c8fcc244862 /src/tracker-extract/Makefile.am
parenteb1f3d93a96ce583d5533bf0c45d859f94e221b3 (diff)
downloadtracker-44eed827e27895a46f08f57693b859674cb7d141.tar.gz
Add systemd user services corresponding to D-Bus session services
The one exception is the email miner, which does not actually have anything to start, so its D-Bus service file won't work anyway. Restart the services on failure, but do not after SIGKILL, because that's what `tracker daemon --kill` (formerly `tracker-control --kill`) does. systemd already treats SIGTERM as a graceful exit which is not considered to be a failure. Loosely based on a patch by Alban Crequy, which only applied this to tracker-store and tracker-miner-fs, and did not have the special handling for SIGKILL. Signed-off-by: Simon McVittie <simon.mcvittie@collabora.co.uk> Bug: https://bugzilla.gnome.org/show_bug.cgi?id=755739 Reviewed-by: Carlos Garnacho
Diffstat (limited to 'src/tracker-extract/Makefile.am')
-rw-r--r--src/tracker-extract/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/tracker-extract/Makefile.am b/src/tracker-extract/Makefile.am
index 3ccc2d08c..1f800a435 100644
--- a/src/tracker-extract/Makefile.am
+++ b/src/tracker-extract/Makefile.am
@@ -585,6 +585,12 @@ service_DATA = org.freedesktop.Tracker1.Miner.Extract.service
INTLTOOL_SERVICE_RULE='%.service: %.service.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< [$]@ -d -u'
@INTLTOOL_SERVICE_RULE@
+tracker-extract.service: tracker-extract.service.in Makefile
+ @sed -e "s|@libexecdir[@]|${libexecdir}|" $< > $@
+
+systemd_userdir = $(prefix)/lib/systemd/user
+systemd_user_DATA = tracker-extract.service
+
install-data-hook:
$(MKDIR_P) "$(DESTDIR)$(datadir)/tracker/miners" && \
$(LN_S) -f "$(servicedir)/$(service_DATA)" \
@@ -620,6 +626,7 @@ CLEANFILES += \
$(autostart_DATA:.desktop=.desktop.in) \
$(service_DATA) \
$(service_DATA:.service=.service.in) \
+ $(systemd_user_DATA) \
$(gsettings_SCHEMAS) \
$(man_MANS)
@@ -627,5 +634,6 @@ EXTRA_DIST += \
$(autostart_DATA:.desktop=.desktop.in.in) \
$(config_DATA) \
$(service_DATA:.service=.service.in.in) \
+ $(systemd_user_DATA:.service=.service.in) \
$(gsettings_SCHEMAS:.xml=.xml.in) \
$(man_MANS)