summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorSam Thursfield <sam@afuera.me.uk>2020-01-24 22:03:06 +0100
committerSam Thursfield <sam@afuera.me.uk>2020-02-17 21:58:49 +0100
commit4d2e9391087b9af7bf1c434b06b48feba4a0d9c8 (patch)
treeebbbe0c8c549d8a5b1a495998fd50f64b46fb5f7 /tests/meson.build
parent302dc53563b0ad4c450074ed6d4b57c76d3b068e (diff)
downloadtracker-4d2e9391087b9af7bf1c434b06b48feba4a0d9c8.tar.gz
tests: Remove the test tracker-store service file
This isn't needed since tracker-store is no longer a separate daemon. Some tests still connect to the session bus but they should no longer autostart any services. Callers should use `dbus-run-session` to create a separate session bus if worried about having test processes talking on the real session bus.
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build33
1 files changed, 5 insertions, 28 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 63740eee6..993c99891 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -16,13 +16,6 @@ if get_option('functional_tests')
subdir('functional-tests')
endif
-subdir('services')
-
-test_bus_conf_file = configure_file(
- input: 'test-bus.conf.in',
- output: 'test-bus.conf',
- configuration: conf)
-
foreach t: tests
test_name = t.get('name')
test_exe = t.get('exe')
@@ -33,31 +26,15 @@ foreach t: tests
# generally indicates a bug or design flaw in that test.
test_is_parallel = t.get('is_parallel', true)
- # This flag marks unit tests which need to contact a D-Bus session bus. This
- # is a sign of a bad unit test -- anything which uses D-Bus belongs in the
- # functional-tests directory.
- test_requires_dbus = t.get('requires_dbus', false)
-
test_env = environment()
test_env.set('TRACKER_LANGUAGE_STOP_WORDS_DIR', join_paths(source_root, 'src', 'libtracker-common', 'stop-words'))
test_env.set('TRACKER_TEST_DOMAIN_ONTOLOGY_RULE', join_paths(source_root, 'src', 'tracker-store', 'default.rule'))
test_env.set('TRACKER_DB_ONTOLOGIES_DIR', join_paths(source_root, 'src', 'ontologies', 'nepomuk'))
test_env.set('LANG', 'en_US.UTF8')
- if test_requires_dbus
- test(test_name, dbus_run_session,
- env: test_env,
- args: ['--config-file=@0@'.format(join_paths(meson.current_build_dir(), 'test-bus.conf')),
- '--',
- test_exe],
- suite: test_suite,
- timeout: test_timeout,
- is_parallel: test_is_parallel)
- else
- test(test_name, test_exe,
- env: test_env,
- timeout: test_timeout,
- suite: test_suite,
- is_parallel: test_is_parallel)
- endif
+ test(test_name, test_exe,
+ env: test_env,
+ timeout: test_timeout,
+ suite: test_suite,
+ is_parallel: test_is_parallel)
endforeach