summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 524b89b3e..6ded545a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2388,6 +2388,11 @@ if test "x$enable_libcue" != "xno" ; then
if test "x$have_libcue" = "xyes"; then
AC_DEFINE(HAVE_LIBCUE, [], [Define if we have libcue])
+
+ PKG_CHECK_EXISTS([libcue >= 2.0.0], have_libcue2=yes, have_libcue2=no)
+ if test "x$have_libcue2" = "xyes"; then
+ AC_DEFINE(HAVE_LIBCUE2, [], [Define if we have libcue 2 or up])
+ fi
fi
else
have_libcue="no (disabled)"
@@ -2399,8 +2404,6 @@ if test "x$enable_libcue" = "xyes"; then
fi
fi
-AM_CONDITIONAL(HAVE_LIBCUE, test "x$have_libcue" = "xyes")
-
####################################################################
# Check for tracker-extract: AbiWord
####################################################################
@@ -2830,7 +2833,7 @@ Metadata Extractors:
Support XML / HTML: $have_libxml2
Support embedded / sidecar XMP: $have_exempi
Support generic media formats: $have_generic_media_handler ($have_generic_media_handler_app) (backend: $gstreamer_backend)
- Support cue sheet parsing: $have_libcue
+ Support cue sheet parsing: $have_libcue (libcue2.0: $have_libcue2)
Support playlists (w/ Totem): $have_playlist
Support ISO image parsing: $have_libosinfo
Support AbiWord document parsing: $have_abiword