summaryrefslogtreecommitdiff
path: root/docs/reference/libtracker-sparql/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'docs/reference/libtracker-sparql/meson.build')
-rw-r--r--docs/reference/libtracker-sparql/meson.build21
1 files changed, 20 insertions, 1 deletions
diff --git a/docs/reference/libtracker-sparql/meson.build b/docs/reference/libtracker-sparql/meson.build
index 507555b2c..3c17c5352 100644
--- a/docs/reference/libtracker-sparql/meson.build
+++ b/docs/reference/libtracker-sparql/meson.build
@@ -10,6 +10,7 @@ endif
gidocgen_dep = dependency('gi-docgen', fallback: ['gi-docgen', 'dummy_dep'])
gidocgen = find_program('gi-docgen')
graphviz_dot = find_program('dot')
+xmlto = find_program('xmlto', required: false)
ontology_introductions = [
'nie-introduction.md',
@@ -82,6 +83,7 @@ foreach doc : generated_ontology_files
'embed-files.py',
meson.current_build_dir() / doc,
meson.current_build_dir() / output_file,
+ meson.current_source_dir(),
],
depends: [base_ontology_docs, nepomuk_ontology_docs, generate_images])
endforeach
@@ -122,9 +124,26 @@ content = [
# The TOML gi-docgen configuration wants a list of quoted file names.
content_quoted = []
foreach c : generated_content + content + generated_ontology_content
- content_quoted += '"@0@"'.format(c)
+ content_quoted += '"@0@"'.format(fs.name(c))
endforeach
+if xmlto.found()
+ cli_reference = custom_target(
+ 'commandline.md',
+ input: 'commandline.md.in',
+ output: 'commandline.md',
+ command: [
+ 'generate-cli-reference.py',
+ '--template', '@INPUT@',
+ '--output', '@OUTPUT@',
+ '--man-pages', manpage_files,
+ ]
+ )
+
+ generated_targets += cli_reference
+ content_quoted += '"@0@"'.format(fs.name(cli_reference.full_path()))
+endif
+
gidocgen_conf = configuration_data()
gidocgen_conf.set('version', meson.project_version())
gidocgen_conf.set('content', ','.join(content_quoted))