summaryrefslogtreecommitdiff
path: root/examples/class-signal/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/class-signal/Makefile.am')
-rw-r--r--examples/class-signal/Makefile.am23
1 files changed, 7 insertions, 16 deletions
diff --git a/examples/class-signal/Makefile.am b/examples/class-signal/Makefile.am
index 313b8fdaf..a4400c95c 100644
--- a/examples/class-signal/Makefile.am
+++ b/examples/class-signal/Makefile.am
@@ -2,23 +2,14 @@ include $(top_srcdir)/Makefile.decl
noinst_PROGRAMS = class-signal
-AM_CPPFLAGS = \
- $(BUILD_CFLAGS) \
- -I$(top_srcdir)/src \
- $(LIBTRACKER_SPARQL_CFLAGS) \
- $(TRACKER_DBUS_CFLAGS)
+AM_CPPFLAGS = \
+ $(BUILD_CFLAGS) \
+ -I$(top_srcdir)/src \
+ $(LIBTRACKER_SPARQL_CFLAGS)
-LDADD = \
+LDADD = \
$(top_builddir)/src/libtracker-sparql/libtracker-sparql-$(TRACKER_API_VERSION).la \
- $(BUILD_LIBS) \
- $(LIBTRACKER_SPARQL_LIBS) \
- $(TRACKER_DBUS_LIBS)
-
-# NOTE: class-signal needed to have gio/dbus/dbus-glib-1 CFLAGS/LIBS
-# added. The reason for this is that the
-# LIBTRACKER_SPARQL_{CFLAGS|LIBS} no longer include dbus/dbus-glib-1
-# so these tests fail without that. The fix is to update the test
-# cases to use gdbus. For now this is a temporary fix for these tests,
-# -mr.
+ $(BUILD_LIBS) \
+ $(LIBTRACKER_SPARQL_LIBS)
class_signal_SOURCES = class-signal.c