summaryrefslogtreecommitdiff
path: root/tests/functional-tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional-tests/Makefile.am')
-rw-r--r--tests/functional-tests/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/functional-tests/Makefile.am b/tests/functional-tests/Makefile.am
index db6225558..ddad7e0fe 100644
--- a/tests/functional-tests/Makefile.am
+++ b/tests/functional-tests/Makefile.am
@@ -8,6 +8,7 @@ SUBDIRS = \
configdir = $(datadir)/tracker-tests
config_DATA = \
+ configuration.json \
trackertest
config_SCRIPTS = \
@@ -51,16 +52,19 @@ TEST_RUNNER = $(top_srcdir)/tests/functional-tests/test-runner.sh
functional-test: ${standard_tests}
for test in ${standard_tests} ; do \
+ export TRACKER_FUNCTIONAL_TEST_CONFIG=$(top_builddir)/tests/functional-tests/configuration.json ; \
$(TEST_RUNNER) python $(top_srcdir)/tests/functional-tests/$$test; \
done
functional-test-slow: ${slow_tests}
@for test in ${slow_tests} ; do \
+ export TRACKER_FUNCTIONAL_TEST_CONFIG=$(top_builddir)/tests/functional-tests/configuration.json \
$(TEST_RUNNER) python $(top_srcdir)/tests/functional-tests/$$test; \
done
EXTRA_DIST = \
$(config_SCRIPTS) \
$(config_DATA) \
+ configuration.json.in \
test-runner.sh \
meson.build