summaryrefslogtreecommitdiff
path: root/tests/functional-tests/ipc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional-tests/ipc/meson.build')
-rw-r--r--tests/functional-tests/ipc/meson.build18
1 files changed, 14 insertions, 4 deletions
diff --git a/tests/functional-tests/ipc/meson.build b/tests/functional-tests/ipc/meson.build
index 8ee7175fe..1c558c514 100644
--- a/tests/functional-tests/ipc/meson.build
+++ b/tests/functional-tests/ipc/meson.build
@@ -3,10 +3,21 @@ functional_ipc_test_c_args = [
'-DTEST_ONTOLOGIES_DIR="@0@"'.format(tracker_uninstalled_nepomuk_ontologies_dir),
]
+tracker_sandbox = find_program(join_paths(source_root, 'utils', 'sandbox', 'tracker-sandbox.py'))
+sandbox_args = ['--dbus-config', test_dbus_config, '--debug-sandbox', '--index-tmpdir', '--']
+
+sandbox_env = environment()
+
+test_env.prepend('PYTHONPATH', tracker_uninstalled_testutils_dir)
+test_env.set('TRACKER_DB_ONTOLOGIES_DIR', tracker_uninstalled_nepomuk_ontologies_dir)
+test_env.set('TRACKER_LANGUAGE_STOP_WORDS_DIR', tracker_uninstalled_stop_words_dir)
+test_env.set('TRACKER_TEST_DOMAIN_ONTOLOGY_RULE', tracker_uninstalled_domain_rule)
+
insert_or_replace_test = executable('test-insert-or-replace',
'test-insert-or-replace.vala', tracker_sparql_vapi,
dependencies: [tracker_common_dep, tracker_sparql_dep])
-test('functional-ipc-insert-or-replace', insert_or_replace_test,
+test('functional-ipc-insert-or-replace', tracker_sandbox,
+ args: sandbox_args + [insert_or_replace_test],
env: test_env)
bus_query_cancellation_test = executable('test-bus-query-cancellation',
@@ -14,7 +25,6 @@ bus_query_cancellation_test = executable('test-bus-query-cancellation',
c_args: functional_ipc_test_c_args,
dependencies: [tracker_common_dep, tracker_sparql_dep])
-test('functional-ipc-bus-query-cancellation',
- test_runner,
- args: bus_query_cancellation_test,
+test('functional-ipc-bus-query-cancellation', tracker_sandbox,
+ args: sandbox_args + [bus_query_cancellation_test],
env: test_env)