summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNalin Dahyabhai <nalin@src.gnome.org>2002-04-29 15:02:15 +0000
committerNalin Dahyabhai <nalin@src.gnome.org>2002-04-29 15:02:15 +0000
commitd1f7309ea90e51362ae3627788ab6e66f675df31 (patch)
treeacb13e8c22778a8a14bcd44174413e6be476616b /Makefile.am
parent3031a899eaa0372f62ac8952f24b1217c846c520 (diff)
downloadvte-d1f7309ea90e51362ae3627788ab6e66f675df31.tar.gz
Handle kb by treating it as a backspace. Make pangox rendering thevte_0_2_2
* src/vte.c: Handle kb by treating it as a backspace. Make pangox rendering the default. Handle control-key sequences better, unless the input method is hiding the modifiers from us. Set the default TERM variable to "xterm-color". * src/vte.c src/vte.h: Get rid of vte_terminal_set_core_font().
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 38e5da42..f4069e09 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,20 +6,24 @@ pkgconfig_DATA = vte.pc
CVSTAG=$(shell echo $(PACKAGE)-$(VERSION) | sed 's,[\.\-],_,g')
+reallytag:
+ cvs tag -cFR $(CVSTAG) .
+
tag:
$(top_srcdir)/autogen.sh
- cvs tag -cFR $(CVSTAG) .
+ $(MAKE) reallytag
archive:
root=`cat $(top_srcdir)/CVS/Root` ; \
repo=`cat $(top_srcdir)/CVS/Repository` ; \
tmpdir=`mktemp -d /tmp/$(PACKAGE)-cvsXXXXXX` ; \
+ dir=`pwd` ; \
cd $$tmpdir ; \
cvs -d $$root export -r $(CVSTAG) $$repo ; \
- cd $$repo ; \
+ cd $$tmpdir/$$repo ; \
./autogen.sh ; \
make distcheck ; \
- cp $(PACKAGE)-$(VERSION).tar.gz $(top_srcdir) ; \
+ cp $(PACKAGE)-$(VERSION).tar.gz $$dir/ ; \
rm -fr $$tmpdir
srpm: $(top_srcdir)/$(PACKAGE)-$(VERSION).tar.gz