summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNalin Dahyabhai <nalin@src.gnome.org>2002-06-10 19:35:31 +0000
committerNalin Dahyabhai <nalin@src.gnome.org>2002-06-10 19:35:31 +0000
commit2173db2433b6405a0b76479f1846094173b231d6 (patch)
tree41e5716cc48352d3d1910891ce4316196ba56927 /configure.in
parentcb97abc8c28ea66334532da0f713c803d2675bbb (diff)
downloadvte-2173db2433b6405a0b76479f1846094173b231d6.tar.gz
Include gettext support. Mark warnings for possible translation. Add.
* Makefile.am, configure.in: Include gettext support. * src/pty.c, src/reaper.c, src/trie.c, src/vte.c: Mark warnings for possible translation. * po/POTFILES.in, po/vte.pot: Add.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d65d79a8..c44e1558 100644
--- a/configure.in
+++ b/configure.in
@@ -2,6 +2,7 @@ AC_INIT(configure.in)
VERSION=`grep ^Version: $srcdir/vte.spec | awk '{print $NF}'`
AM_INIT_AUTOMAKE(vte,$VERSION)
AM_PROG_LIBTOOL
+AM_GLIB_GNU_GETTEXT
AC_EGREP_CPP(glibc,
[
#include <stdio.h>
@@ -72,6 +73,11 @@ if test x$prefix = xNONE ; then
fi
AC_DEFINE_UNQUOTED(DATADIR,"$mydatadir",
[The location where arch-independent package-specific data can be found.])
+AC_DEFINE_UNQUOTED(LOCALEDIR,"$mydatadir/locale",
+ [The location where locale data can be found.])
+
+GETTEXT_PACKAGE="$PACKAGE"
+AC_SUBST(GETTEXT_PACKAGE)
AM_CONFIG_HEADER(config.h)
-AC_OUTPUT([Makefile src/Makefile termcaps/Makefile vte.pc])
+AC_OUTPUT([Makefile src/Makefile termcaps/Makefile po/Makefile.in vte.pc])