summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNalin Dahyabhai <nalin@src.gnome.org>2002-09-11 22:05:26 +0000
committerNalin Dahyabhai <nalin@src.gnome.org>2002-09-11 22:05:26 +0000
commit5d1ac721e2096e926afb66b0f693cfdd6d0a8a37 (patch)
tree51ddda07cd40cd1343126c70f5e4759efa8f76c3 /configure.in
parent0455940575c4f71862b3c5c9154f43e15e0b5d02 (diff)
downloadvte-5d1ac721e2096e926afb66b0f693cfdd6d0a8a37.tar.gz
Reorder definitions to avoid implicit declaration warnings. Check for
* src/pty.c: Reorder definitions to avoid implicit declaration warnings. * configure.in: Check for socketpair(). Check for socket() in libc before poking around in libsocket. * gnome-pty-helper/configure.in: Check for openpty() in libutil as well, and do so before we check for other functions.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 5bf93a63..b022c745 100644
--- a/configure.in
+++ b/configure.in
@@ -55,10 +55,10 @@ AC_DEFINE(PANGO_DISABLE_DEPRECATED,1,[Disable deprecated pango features.])
AC_DEFINE(VTE_UTF8_BPC,6,[Maximum number of bytes used per UTF-8 character.])
AC_DEFINE_UNQUOTED(PACKAGE,"$PACKAGE",[Package name.])
AC_CHECK_FUNCS(getpt grantpt unlockpt ptsname ptsname_r sendmsg)
+AC_CHECK_FUNC(socket,,AC_CHECK_LIB(socket,socket))
+AC_CHECK_FUNC(socketpair,,AC_CHECK_LIB(socket,socketpair))
AC_CHECK_HEADERS(sys/un.h stropts.h termios.h wchar.h)
-AC_CHECK_LIB(socket, socket)
-
if test x$USE_MAINTAINER_MODE != x ; then
if test x$USE_MAINTAINER_MODE != xno ; then
if test x$GCC = xyes ; then