summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristian Persch <chpe@src.gnome.org>2021-03-25 19:26:57 +0100
committerChristian Persch <chpe@src.gnome.org>2021-03-25 19:26:57 +0100
commit1e674130bf231208e8f33006b78913095dd7e5a8 (patch)
tree22ea47b0c38b65642ed712f880a06b2ea453ef97 /meson.build
parent21685ded3e4a1dba02822ba248b0445e24a58dab (diff)
downloadvte-1e674130bf231208e8f33006b78913095dd7e5a8.tar.gz
build: Work around a meson bug with dist scripts in subprojects
https://github.com/mesonbuild/meson/issues/8440 Fixes: https://gitlab.gnome.org/GNOME/vte/-/issues/345
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 7 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 2de7652d..4f5a7c57 100644
--- a/meson.build
+++ b/meson.build
@@ -525,9 +525,13 @@ endif
# Dist
-meson.add_dist_script(
- find_program('meson_changelog.sh'),
-)
+# Meson bug https://github.com/mesonbuild/meson/issues/8440 breaks using vte
+# as subproject; see vte#345.
+if meson.version().version_compare('>= 0.58.0') or not meson.is_subproject()
+ meson.add_dist_script(
+ find_program('meson_changelog.sh'),
+ )
+endif
# Simple compat Makefile