summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristian Persch <chpe@src.gnome.org>2019-11-11 22:10:34 +0100
committerChristian Persch <chpe@src.gnome.org>2019-11-11 22:10:34 +0100
commit623f3c66de097eefef44001a4ff70600c11313f9 (patch)
tree4d52035e2944c5abedbd783434fa27754f1091b4 /meson.build
parent75196cef0150cb46385961a1b1d4ad7fb2e9791a (diff)
downloadvte-623f3c66de097eefef44001a4ff70600c11313f9.tar.gz
build: Add configure switch to disable a11y code
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 28514566..4e79657a 100644
--- a/meson.build
+++ b/meson.build
@@ -114,6 +114,7 @@ config_h = configuration_data()
config_h.set_quoted('GETTEXT_PACKAGE', vte_gettext_domain)
config_h.set_quoted('VERSION', vte_version)
config_h.set('VTE_DEBUG', enable_debug)
+config_h.set('WITH_A11Y', get_option('a11y'))
config_h.set('WITH_FRIBIDI', get_option('fribidi'))
config_h.set('WITH_GNUTLS', get_option('gnutls'))
config_h.set('WITH_ICONV', get_option('iconv'))
@@ -478,6 +479,8 @@ output += ' C++ compiler: ' + cxx.get_id() + ' (version ' + cxx.version() + ')\
output += '\n'
output += ' Coverage: ' + get_option('b_coverage').to_string() + '\n'
output += ' Debug: ' + enable_debug.to_string() + '\n'
+output += '\n'
+output += ' A11y: ' + get_option('a11y').to_string() + '\n'
output += ' Docs: ' + get_option('docs').to_string() + '\n'
output += ' FRIBIDI: ' + get_option('fribidi').to_string() + '\n'
output += ' GNUTLS: ' + get_option('gnutls').to_string() + '\n'