summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorHans Petter Jansson <hpj@cl.no>2020-08-08 21:55:09 +0200
committerChristian Persch <chpe@src.gnome.org>2020-08-08 21:55:09 +0200
commit9b879a3c326118ec8bd7657a7ac11d78f084e6c0 (patch)
tree93bb172f941e72e0ccfb080293b9e0b765f5c5be /meson.build
parentacc15425af882bb541bff14557bafbdc77530c7d (diff)
downloadvte-9b879a3c326118ec8bd7657a7ac11d78f084e6c0.tar.gz
all: Add SIXEL support
This adds support for SIXEL images to VTE. Based on initial work by Hayaki Saito <saitoha@me.com>, updated and improved by Hans Petter Jansson <hpj@cl.no> For now this is off by default; build with -Dsixel=true to enable. (This is the contents of the wip/sixels branch, squashed together into one commit.) https://gitlab.gnome.org/GNOME/vte/-/issues/253
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 11ca2f9a..b77d2a18 100644
--- a/meson.build
+++ b/meson.build
@@ -124,6 +124,7 @@ config_h.set('WITH_A11Y', get_option('a11y'))
config_h.set('WITH_FRIBIDI', get_option('fribidi'))
config_h.set('WITH_GNUTLS', get_option('gnutls'))
config_h.set('WITH_ICU', get_option('icu'))
+config_h.set('WITH_SIXEL', get_option('sixel'))
ver = glib_min_req_version.split('.')
config_h.set('GLIB_VERSION_MIN_REQUIRED', '(G_ENCODE_VERSION(' + ver[0] + ',' + ver[1] + '))')
@@ -505,6 +506,7 @@ output += ' GTK+ 4.0: ' + get_option('gtk4').to_string() + '\n'
output += ' ICU: ' + get_option('icu').to_string() + '\n'
output += ' GIR: ' + get_option('gir').to_string() + '\n'
output += ' systemd: ' + systemd_dep.found().to_string() + '\n'
+output += ' SIXEL: ' + get_option('sixel').to_string() + '\n'
output += ' Vala: ' + get_option('vapi').to_string() + '\n'
output += '\n'
output += ' Prefix: ' + get_option('prefix') + '\n'