summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Hult <rhult@codefactory.se>2001-12-01 12:00:43 +0000
committerRichard Hult <rhult@src.gnome.org>2001-12-01 12:00:43 +0000
commit36c73f747bad97497ea3339b42a259a3db518911 (patch)
treefdef9bba2f3ec9e71f238d02429b11d2f7bde63c /Makefile.am
parent57c850dc83adf9638426c0a289fb3cea2bc1ba98 (diff)
downloadyelp-36c73f747bad97497ea3339b42a259a3db518911.tar.gz
Exit when the window is closed.
2001-12-01 Richard Hult <rhult@codefactory.se> * src/main.c (main): Exit when the window is closed. * src/*.c: Mark strings as translatable. * src/main.c (main): Init gettext. * acconfig.h: Add. * configure.in: Gettextize and intltoolize. * autogen.sh: Redirect to the installed one for gnome 2. * yelp.desktop.in: Desktop file. * Makefile.am: Add a desktop file and intltool rule for it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index af437a64..083e3a82 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1 +1,17 @@
-SUBDIRS = src
+SUBDIRS = src po
+
+@INTLTOOL_DESKTOP_RULE@
+
+DESKTOP_IN_FILES=yelp.desktop.in
+DESKTOP_FILES=$(DESKTOP_IN_FILES:.desktop.in=.desktop)
+
+Applicationsdir = $(datadir)/gnome/apps/Applications
+Applications_DATA = $(DESKTOP_FILES)
+
+EXTRA_DIST = \
+ intltool-extract.in \
+ intltool-merge.in \
+ intltool-update.in \
+ $(DESKTOP_IN_FILES) \
+ $(DESKTOP_FILES)
+