summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Mustieles <daniel.mustieles@gmail.com>2014-09-12 12:22:04 +0200
committerKalev Lember <klember@redhat.com>2018-03-23 16:45:15 +0100
commit92645b012abd631a2356be74f9522ee187a0f46b (patch)
tree778db5dad84fc2b591ed9fec2c2f5f3fab5167c8 /Makefile.am
parenteb2e56bdf28c494558f80bee48b2c8acd5b00607 (diff)
downloadyelp-92645b012abd631a2356be74f9522ee187a0f46b.tar.gz
Add AppData file
Various fixes and appdata updates by Kalev Lember <klember@redhat.com> and David King <amigadave@amigadave.com>. https://bugzilla.gnome.org/show_bug.cgi?id=722763
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7b82649d..89b4d6a3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -284,6 +284,12 @@ desktopdir = $(datadir)/applications
desktop_in_files=yelp.desktop.in.in
desktop_DATA = $(desktop_in_files:.desktop.in.in=.desktop)
+@INTLTOOL_XML_RULE@
+
+appstream_in_files = data/yelp.appdata.xml.in
+appstream_XML = $(appstream_in_files:.appdata.xml.in=.appdata.xml)
+@APPSTREAM_XML_RULES@
+
@INTLTOOL_SCHEMAS_RULE@
gsettings_SCHEMAS = data/org.gnome.yelp.gschema.xml
@@ -683,6 +689,7 @@ xsl_DATA = \
data/xslt/yelp-common.xsl
dist_noinst_DATA = \
+ $(appstream_in_files) \
$(desktop_in_files) \
$(gsettings_SCHEMAS) \
$(libyelp_libyelp_la_headers) \
@@ -859,6 +866,7 @@ dist_noinst_SCRIPTS = \
autogen.sh
CLEANFILES = \
+ $(appstream_XML) \
$(desktop_DATA) \
$(enum_data) \
$(marshal_data)