summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-11-30 22:25:18 +0000
committerChristian Persch <chpe@src.gnome.org>2005-11-30 22:25:18 +0000
commit7acdf4277b2328796f16c58b942e98c067b8a638 (patch)
tree0ab42a8513d23d223bdc7f020ec954ea3c1165ea /Makefile.am
parent0f59a2e9c27894680358a9c9362cd4ea98670ecb (diff)
downloadyelp-7acdf4277b2328796f16c58b942e98c067b8a638.tar.gz
Use gecko.m4 from Epiphany to detect gecko and set the various compiler
2005-11-30 Christian Persch <chpe@cvs.gnome.org> * Makefile.am: * autogen.sh: * configure.in: * data/Makefile.am: * m4/gecko.m4: * src/Makefile.am: Use gecko.m4 from Epiphany to detect gecko and set the various compiler flags etc. Bug #322171. * src/Yelper.cpp: Use nsIWebBrowserSetup to turn off the global history. Bug #322170.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 10 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index cf222dcd..1798e4e0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,29 +1,30 @@
SUBDIRS = src stylesheets po data
-@INTLTOOL_DESKTOP_RULE@
+ACLOCAL_AMFLAGS = -I m4
-DESKTOP_IN_FILES=yelp.desktop.in
-DESKTOP_FILES=$(DESKTOP_IN_FILES:.desktop.in=.desktop)
+@INTLTOOL_DESKTOP_RULE@
-Applicationsdir = $(datadir)/applications
-Applications_DATA = $(DESKTOP_FILES)
+desktopdir = $(datadir)/applications
+desktop_in_files=yelp.desktop.in.in
+desktop_DATA = $(desktop_in_files:.desktop.in.in=.desktop)
yelpdatadir = $(datadir)/yelp
yelpdata_DATA = important_docs.xml
-
EXTRA_DIST = \
+ autogen.sh \
intltool-extract.in \
intltool-merge.in \
intltool-update.in \
idl/GNOME_Yelp.idl \
important_docs.xml \
- $(DESKTOP_IN_FILES) \
- $(DESKTOP_FILES)
+ $(desktop_in_files)
DISTCLEANFILES = \
intltool-extract \
intltool-merge \
intltool-update
-CLEANFILES = yelp.desktop
+CLEANFILES = $(desktop_DATA)
+
+DISTCHECK_CONFIGURE_FLAGS = --disable-scrollkeeper